summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorpre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com>2022-10-11 07:09:07 +0200
committerGitHub <noreply@github.com>2022-10-11 07:09:07 +0200
commitc15278d7b6ed2ed2847ddbdd679615d707d8fb6a (patch)
tree38f2056025a852d01039b6ddfcde93fd9cb3bec5 /.pre-commit-config.yaml
parentb0220bdd11d3fe0a18f6d8bed2402cba6fd5dfc2 (diff)
downloadastroid-git-c15278d7b6ed2ed2847ddbdd679615d707d8fb6a.tar.gz
[pre-commit.ci] pre-commit autoupdate (#1829)
* [pre-commit.ci] pre-commit autoupdate updates: - [github.com/PyCQA/autoflake: v1.6.1 → v1.7.2](https://github.com/PyCQA/autoflake/compare/v1.6.1...v1.7.2) - [github.com/asottile/pyupgrade: v2.38.2 → v3.1.0](https://github.com/asottile/pyupgrade/compare/v2.38.2...v3.1.0) - [github.com/psf/black: 22.8.0 → 22.10.0](https://github.com/psf/black/compare/22.8.0...22.10.0) - [github.com/pre-commit/mirrors-mypy: v0.981 → v0.982](https://github.com/pre-commit/mirrors-mypy/compare/v0.981...v0.982) - [github.com/pre-commit/mirrors-prettier: v3.0.0-alpha.0 → v3.0.0-alpha.1](https://github.com/pre-commit/mirrors-prettier/compare/v3.0.0-alpha.0...v3.0.0-alpha.1) * Update .pre-commit-config.yaml Co-authored-by: pre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com> Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 946e2d91..a8b1176d 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -28,7 +28,7 @@ repos:
exclude: tests/testdata|setup.py
types: [python]
- repo: https://github.com/asottile/pyupgrade
- rev: v2.38.2
+ rev: v3.1.0
hooks:
- id: pyupgrade
exclude: tests/testdata
@@ -44,7 +44,7 @@ repos:
- id: black-disable-checker
exclude: tests/unittest_nodes_lineno.py
- repo: https://github.com/psf/black
- rev: 22.8.0
+ rev: 22.10.0
hooks:
- id: black
args: [--safe, --quiet]
@@ -71,7 +71,7 @@ repos:
]
exclude: tests/testdata|conf.py
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v0.981
+ rev: v0.982
hooks:
- id: mypy
name: mypy
@@ -90,7 +90,7 @@ repos:
]
exclude: tests/testdata| # exclude everything, we're not ready
- repo: https://github.com/pre-commit/mirrors-prettier
- rev: v3.0.0-alpha.0
+ rev: v3.0.0-alpha.1
hooks:
- id: prettier
args: [--prose-wrap=always, --print-width=88]