summaryrefslogtreecommitdiff
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 946e2d91..a8b1176d 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -28,7 +28,7 @@ repos:
exclude: tests/testdata|setup.py
types: [python]
- repo: https://github.com/asottile/pyupgrade
- rev: v2.38.2
+ rev: v3.1.0
hooks:
- id: pyupgrade
exclude: tests/testdata
@@ -44,7 +44,7 @@ repos:
- id: black-disable-checker
exclude: tests/unittest_nodes_lineno.py
- repo: https://github.com/psf/black
- rev: 22.8.0
+ rev: 22.10.0
hooks:
- id: black
args: [--safe, --quiet]
@@ -71,7 +71,7 @@ repos:
]
exclude: tests/testdata|conf.py
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v0.981
+ rev: v0.982
hooks:
- id: mypy
name: mypy
@@ -90,7 +90,7 @@ repos:
]
exclude: tests/testdata| # exclude everything, we're not ready
- repo: https://github.com/pre-commit/mirrors-prettier
- rev: v3.0.0-alpha.0
+ rev: v3.0.0-alpha.1
hooks:
- id: prettier
args: [--prose-wrap=always, --print-width=88]