summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel van Noord <13665637+DanielNoord@users.noreply.github.com>2023-04-26 09:42:26 +0200
committerDaniƫl van Noord <13665637+DanielNoord@users.noreply.github.com>2023-04-26 12:37:54 +0200
commitf5f4a3603a2a1a34ede3b566ba8943af7a2b7b5a (patch)
treef69d39afbcbeb5e95fce630d44a594f5edf434d7
parentdb6d29da5b91d05acd032adae800538b35dff0ad (diff)
downloadastroid-git-f5f4a3603a2a1a34ede3b566ba8943af7a2b7b5a.tar.gz
Add package data to ``pyprojecttoml``
-rw-r--r--pyproject.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 78da1117..9b3d4272 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -45,6 +45,14 @@ license-files = ["LICENSE", "CONTRIBUTORS.txt"] # Keep in sync with setup.cfg
[tool.setuptools.packages.find]
include = ["astroid*"]
+[tool.setuptools.package-data]
+"*" = [
+ "../requirements*.txt",
+ "../tox.ini",
+ "../tests/__init__.py",
+ "../tests/resources.py",
+]
+
[tool.setuptools.dynamic]
version = {attr = "astroid.__pkginfo__.__version__"}