summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorChristian Clauss <cclauss@me.com>2022-09-18 09:28:34 +0200
committerGitHub <noreply@github.com>2022-09-18 09:28:34 +0200
commit354e4dfbeb140d66b88edfa681df2063d6ae1a9a (patch)
treeecdf9bf94ea1d85f320d5f1c85c8835926badff0 /setup.cfg
parentbed16016ae465cd6d19aa01ad5772e9d5045bbdc (diff)
downloadastroid-git-354e4dfbeb140d66b88edfa681df2063d6ae1a9a.tar.gz
Migrate configs for isort, mypy, and pytest into pyproject.toml (#1789)
Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com>
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg51
1 files changed, 0 insertions, 51 deletions
diff --git a/setup.cfg b/setup.cfg
index 6223228e..9fda04b0 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -8,22 +8,6 @@ license_files =
LICENSE
CONTRIBUTORS.txt
-[aliases]
-test = pytest
-
-[tool:pytest]
-testpaths = tests
-python_files = *test_*.py
-addopts = -m "not acceptance"
-
-[isort]
-multi_line_output = 3
-line_length = 88
-known_third_party = sphinx, pytest, six, nose, numpy, attr
-known_first_party = astroid
-include_trailing_comma = True
-skip_glob = tests/testdata
-
[flake8]
extend-ignore =
F401, # Unused imports
@@ -36,38 +20,3 @@ select = B,C,E,F,W,T4,B9
# Required for flake8-typing-imports (v1.12.0)
# The plugin doesn't yet read the value from pyproject.toml
min_python_version = 3.7.2
-
-[mypy]
-scripts_are_modules = True
-no_implicit_optional = True
-warn_redundant_casts = True
-show_error_codes = True
-enable_error_code = ignore-without-code
-
-[mypy-setuptools]
-ignore_missing_imports = True
-
-[mypy-pytest]
-ignore_missing_imports = True
-
-[mypy-nose.*]
-ignore_missing_imports = True
-
-[mypy-numpy.*]
-ignore_missing_imports = True
-
-[mypy-_io.*]
-ignore_missing_imports = True
-
-[mypy-wrapt.*]
-ignore_missing_imports = True
-
-[mypy-lazy_object_proxy.*]
-ignore_missing_imports = True
-
-[mypy-gi.*]
-ignore_missing_imports = True
-
-[mypy-importlib.*]
-# Importlib typeshed stubs do not include the private functions we use
-ignore_missing_imports = True