summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorChristian Clauss <cclauss@me.com>2022-09-18 08:28:17 +0200
committerGitHub <noreply@github.com>2022-09-18 08:28:17 +0200
commitbed16016ae465cd6d19aa01ad5772e9d5045bbdc (patch)
treea75ca4cf0752f1f718ae8b0bdc36ef9bd921cb56 /setup.cfg
parente9162adef069e19147717d00075b811550ebd27c (diff)
downloadastroid-git-bed16016ae465cd6d19aa01ad5772e9d5045bbdc.tar.gz
Activate's flake8 max-complexity and max-line-length with a high enough value (#1790)
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.cfg b/setup.cfg
index f5dca363..6223228e 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -26,15 +26,12 @@ skip_glob = tests/testdata
[flake8]
extend-ignore =
- C901, # Function complexity checker
F401, # Unused imports
E203, # Incompatible with black see https://github.com/psf/black/issues/315
W503, # Incompatible with black
- E501, # Line too long
- B950, # Line too long
B901 # Combine yield and return statements in one function
-max-line-length=88
-max-complexity = 20
+max-complexity = 83
+max-line-length = 138
select = B,C,E,F,W,T4,B9
# Required for flake8-typing-imports (v1.12.0)
# The plugin doesn't yet read the value from pyproject.toml