summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.cfg b/setup.cfg
index f5dca363..6223228e 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -26,15 +26,12 @@ skip_glob = tests/testdata
[flake8]
extend-ignore =
- C901, # Function complexity checker
F401, # Unused imports
E203, # Incompatible with black see https://github.com/psf/black/issues/315
W503, # Incompatible with black
- E501, # Line too long
- B950, # Line too long
B901 # Combine yield and return statements in one function
-max-line-length=88
-max-complexity = 20
+max-complexity = 83
+max-line-length = 138
select = B,C,E,F,W,T4,B9
# Required for flake8-typing-imports (v1.12.0)
# The plugin doesn't yet read the value from pyproject.toml