summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonard Richardson <leonardr@segfault.org>2016-07-26 21:28:13 -0400
committerLeonard Richardson <leonardr@segfault.org>2016-07-26 21:28:13 -0400
commit50882562767b2445d504dc55b627c51c60364ecb (patch)
tree9ea530bab21c25d70e6ec94e265bfa403533ab04
parentaaf42d1ce88c98c82560cfabc41186c8f82e05f0 (diff)
parent922d580ff2bc44dc3e498b9c53b2530ec2bd76b9 (diff)
downloadbeautifulsoup4-50882562767b2445d504dc55b627c51c60364ecb.tar.gz
Clarify that Beautiful Soup is no longer compatible with versions of Python pre-2.7. Contributed by Ville Skyttä.
-rw-r--r--bs4/__init__.py2
-rw-r--r--bs4/tests/test_soup.py3
-rw-r--r--setup.py2
3 files changed, 3 insertions, 4 deletions
diff --git a/bs4/__init__.py b/bs4/__init__.py
index 6eb3b04..9a6e73f 100644
--- a/bs4/__init__.py
+++ b/bs4/__init__.py
@@ -8,7 +8,7 @@ Beautiful Soup uses a pluggable XML or HTML parser to parse a
provides methods and Pythonic idioms that make it easy to navigate,
search, and modify the parse tree.
-Beautiful Soup works with Python 2.6 and up. It works better if lxml
+Beautiful Soup works with Python 2.7 and up. It works better if lxml
and/or html5lib is installed.
For more than you ever wanted to know about Beautiful Soup, see the
diff --git a/bs4/tests/test_soup.py b/bs4/tests/test_soup.py
index 780d288..f3e69ed 100644
--- a/bs4/tests/test_soup.py
+++ b/bs4/tests/test_soup.py
@@ -35,7 +35,6 @@ try:
except ImportError, e:
LXML_PRESENT = False
-PYTHON_2_PRE_2_7 = (sys.version_info < (2,7))
PYTHON_3_PRE_3_2 = (sys.version_info[0] == 3 and sys.version_info < (3,2))
class TestConstructor(SoupTest):
@@ -279,7 +278,7 @@ class TestEncodingConversion(SoupTest):
self.assertEqual(soup_from_unicode.encode('utf-8'), self.utf8_data)
@skipIf(
- PYTHON_2_PRE_2_7 or PYTHON_3_PRE_3_2,
+ PYTHON_3_PRE_3_2,
"Bad HTMLParser detected; skipping test of non-ASCII characters in attribute name.")
def test_attribute_name_containing_unicode_characters(self):
markup = u'<div><a \N{SNOWMAN}="snowman"></a></div>'
diff --git a/setup.py b/setup.py
index 2952547..a1e42bb 100644
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,7 @@ setup(
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
'Programming Language :: Python :: 3',
"Topic :: Text Processing :: Markup :: HTML",
"Topic :: Text Processing :: Markup :: XML",