summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2017-01-15 17:18:45 +0100
committerArmin Rigo <arigo@tunes.org>2017-01-15 17:18:45 +0100
commit4f4228eb5ccac7ae3cb838d2055c6301b7d7b35f (patch)
treec7609f41801f2857a8979dff3c5b8e822903e222 /README.md
parentdc4c58c23c9bb9bb76ef7242fc4ce3ad6e6b4e54 (diff)
downloadcffi-4f4228eb5ccac7ae3cb838d2055c6301b7d7b35f.tar.gz
Add more tips
Diffstat (limited to 'README.md')
-rw-r--r--README.md8
1 files changed, 8 insertions, 0 deletions
diff --git a/README.md b/README.md
index 542a0f5..4df4405 100644
--- a/README.md
+++ b/README.md
@@ -15,7 +15,15 @@ Contact
[Mailing list](https://groups.google.com/forum/#!forum/python-cffi)
+Testing/development tips
+------------------------
+
To run tests under CPython, run::
+ pip install pytest # if you don't have py.test already
python setup.py build_ext -f -i
py.test c/ test/
+
+If you run in another directory (either the tests or another program),
+you should use the environment variable ``PYTHONPATH=/path`` to point
+to the location that contains the ``_cffi_backend.so`` just compiled.