summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2020-07-11 14:01:18 +0200
committerArmin Rigo <arigo@tunes.org>2020-07-11 14:01:18 +0200
commit56207d5c8b9dd155bb08522e397a42224caa1fea (patch)
tree87db4a427836909bc1572be42169fea7be8a1113 /setup.py
parentecd6c1e30970271a3f73e27792e95c1413663d92 (diff)
downloadcffi-56207d5c8b9dd155bb08522e397a42224caa1fea.tar.gz
add commentmacos11
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fc8d705..8216851 100644
--- a/setup.py
+++ b/setup.py
@@ -150,7 +150,10 @@ if COMPILE_LIBFFI:
for filename in _filenames)
else:
if 'darwin' in sys.platform and macosx_deployment_target() >= (10, 15):
- # use libffi from Mac OS SDK
+ # use libffi from Mac OS SDK if we're targetting 10.15 (including
+ # on arm64). This libffi is safe against the crash-after-fork
+ # issue described in _cffi_backend.c. Also, arm64 uses a different
+ # ABI for calls to vararg functions as opposed to regular functions.
extra_compile_args += ['-iwithsysroot/usr/include/ffi']
define_macros += [('CFFI_TRUST_LIBFFI', '1'),
('HAVE_FFI_PREP_CIF_VAR', '1')]