summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2013-11-18 14:26:01 +0100
committerArmin Rigo <arigo@tunes.org>2013-11-18 14:26:01 +0100
commitb9a970116aa0f005f1be828dd886a7efc1803924 (patch)
treed84889cd55ac4f545896d4c11d6baf5c26ee3ae4 /setup.py
parenteb6c5db4e8fa6ea96aa0bfbc074b154b258113b8 (diff)
downloadcffi-b9a970116aa0f005f1be828dd886a7efc1803924.tar.gz
Bah. "print >> sys.stderr, ..." is syntactically valid on Python 3,
but does nonsense.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 497a4df..f8c7f83 100644
--- a/setup.py
+++ b/setup.py
@@ -48,8 +48,8 @@ def ask_supports_thread():
try:
compiler.compile(['c/check__thread.c'])
except distutils.errors.CompileError:
- print >> sys.stderr, "the above error message can be safely ignored;"
- print >> sys.stderr, "will not use '__thread' in the C code"
+ sys.stderr.write("the above error message can be safely ignored;\n")
+ sys.stderr.write("will not use '__thread' in the C code\n")
else:
define_macros.append(('USE__THREAD', None))
try: