summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorDoug Harris <dharris@truthinitiative.org>2018-05-14 11:01:23 -0400
committerDoug Harris <dharris@truthinitiative.org>2018-05-14 11:25:33 -0400
commit4ebaff2a93d3914c940b99fd17894fb96d220cd4 (patch)
tree6dd980dd549dad095777e6d876f8e246bf97cd68 /README.rst
parent4cc1b9e938a42bfd97c46f4ff193f48e770f6160 (diff)
downloadclick-4ebaff2a93d3914c940b99fd17894fb96d220cd4.tar.gz
Updating README to match flask style.
Also added `long_description` to setup.py for PyPI happiness.
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst92
1 files changed, 92 insertions, 0 deletions
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..07352ad
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,92 @@
+\$ click\_
+==========
+
+What's Click?
+-------------
+
+Click is a Python package for creating beautiful command line interfaces
+in a composable way with as little code as necessary. It's the "Command
+Line Interface Creation Kit". It's highly configurable but comes with
+sensible defaults out of the box.
+
+It aims to make the process of writing command line tools quick and fun
+while also preventing any frustration caused by the inability to implement
+an intended CLI API.
+
+Click in three points:
+ - arbitrary nesting of commands
+ - automatic help page generation
+ - supports lazy loading of subcommands at runtime
+
+
+Installing
+----------
+
+Install and update using `pip`_:
+
+.. code-block:: text
+
+ $ pip install click
+
+A Simple Example
+----------------
+
+What does it look like? Here is an example of a simple Click program:
+
+.. code-block:: python
+
+ import click
+
+ @click.command()
+ @click.option('--count', default=1, help='Number of greetings.')
+ @click.option('--name', prompt='Your name',
+ help='The person to greet.')
+ def hello(count, name):
+ """Simple program that greets NAME for a total of COUNT times."""
+ for x in range(count):
+ click.echo('Hello %s!' % name)
+
+ if __name__ == '__main__':
+ hello()
+
+And what it looks like when run:
+
+.. code-block:: text
+
+ $ python hello.py --count=3
+ Your name: John
+ Hello John!
+ Hello John!
+ Hello John!
+
+Donate
+------
+
+The Pallets organization develops and supports Flask and the libraries
+it uses. In order to grow the community of contributors and users, and
+allow the maintainers to devote more time to the projects, `please
+donate today`_.
+
+.. _please donate today: https://psfmember.org/civicrm/contribute/transact?reset=1&id=20
+
+
+Links
+-----
+
+* Website: https://www.palletsprojects.com/p/click/
+* Documentation: http://click.pocoo.org/
+* License: `BSD <https://github.com/pallets/click/blob/master/LICENSE>`_
+* Releases: https://pypi.org/project/click/
+* Code: https://github.com/pallets/click
+* Issue tracker: https://github.com/pallets/click/issues
+* Test status:
+
+ * Linux, Mac: https://travis-ci.org/pallets/click
+ * Windows: https://ci.appveyor.com/project/pallets/click
+
+* Test coverage: https://codecov.io/gh/pallets/click
+
+.. _WSGI: https://wsgi.readthedocs.io
+.. _Werkzeug: https://www.palletsprojects.com/p/werkzeug/
+.. _Jinja: https://www.palletsprojects.com/p/jinja/
+.. _pip: https://pip.pypa.io/en/stable/quickstart/