summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES2
-rw-r--r--click/termui.py8
-rw-r--r--click/types.py2
-rw-r--r--click/utils.py4
-rw-r--r--examples/colors/setup.py2
-rw-r--r--examples/termui/setup.py2
6 files changed, 10 insertions, 10 deletions
diff --git a/CHANGES b/CHANGES
index 100cdce..4bfe3b9 100644
--- a/CHANGES
+++ b/CHANGES
@@ -8,7 +8,7 @@ Version 2.0
(codename and release date to be decided)
-- added support for opening stdin/stdout on windows in
+- added support for opening stdin/stdout on Windows in
binary mode correctly.
- added support for atomic writes to files by going through
a temporary file.
diff --git a/click/termui.py b/click/termui.py
index 527fe61..53dc87c 100644
--- a/click/termui.py
+++ b/click/termui.py
@@ -58,7 +58,7 @@ def prompt(text, default=None, hide_input=False,
f = hide_input and hidden_prompt_func or visible_prompt_func
try:
# Write the prompt separately so that we get nice
- # coloring through colorama on windows
+ # coloring through colorama on Windows
echo(text, nl=False)
return f('')
except (KeyboardInterrupt, EOFError):
@@ -114,7 +114,7 @@ def confirm(text, default=False, abort=False, prompt_suffix=': ',
while 1:
try:
# Write the prompt separately so that we get nice
- # coloring through colorama on windows
+ # coloring through colorama on Windows
echo(prompt, nl=False)
value = visible_prompt_func('').lower().strip()
except (KeyboardInterrupt, EOFError):
@@ -267,7 +267,7 @@ def clear():
"""
if not isatty(sys.stdout):
return
- # If we're on windows and we don't have colorama available, then we
+ # If we're on Windows and we don't have colorama available, then we
# clear the screen by shelling out. Otherwise we can use an escape
# sequence.
if sys.platform.startswith('win') and colorama is None:
@@ -386,7 +386,7 @@ def edit(text=None, editor=None, env=None, require_save=True,
If the editor cannot be opened a :exc:`UsageError` is raised.
Note for Windows: to simplify cross platform usage the newlines are
- automatically converted from posix to windows and reverse. As such the
+ automatically converted from POSIX to Windows and reverse. As such the
message here will have ``\n`` as newline markers.
:param text: the text to edit.
diff --git a/click/types.py b/click/types.py
index b691d30..4ae0cda 100644
--- a/click/types.py
+++ b/click/types.py
@@ -29,7 +29,7 @@ class ParamType(object):
#: means any whitespace. For all parameters the general rule is that
#: whitespace splits them up. The exception are paths and files which
#: are split by ``os.path.pathsep`` by default (":" on unix and ";" on
- #: windows).
+ #: Windows).
envvar_list_splitter = None
def __call__(self, value, param=None, ctx=None):
diff --git a/click/utils.py b/click/utils.py
index f39b390..875529c 100644
--- a/click/utils.py
+++ b/click/utils.py
@@ -320,11 +320,11 @@ def get_app_dir(app_name, roaming=True, force_posix=False):
Mac OS X:
``~/Library/Application Support/Foo Bar``
- Mac OS X (posix):
+ Mac OS X (POSIX):
``~/.foo-bar``
Unix:
``~/.config/foo-bar``
- Unix (posix):
+ Unix (POSIX):
``~/.foo-bar``
Win XP (roaming):
``C:\Documents and Settings\<user>\Local Settings\Application Data\Foo Bar``
diff --git a/examples/colors/setup.py b/examples/colors/setup.py
index 482ccb7..1a87b2d 100644
--- a/examples/colors/setup.py
+++ b/examples/colors/setup.py
@@ -7,7 +7,7 @@ setup(
include_package_data=True,
install_requires=[
'Click',
- # Colorama is only required for windows.
+ # Colorama is only required for Windows.
'colorama',
],
entry_points='''
diff --git a/examples/termui/setup.py b/examples/termui/setup.py
index c4a75dd..8478cf8 100644
--- a/examples/termui/setup.py
+++ b/examples/termui/setup.py
@@ -7,7 +7,7 @@ setup(
include_package_data=True,
install_requires=[
'Click',
- # Colorama is only required for windows.
+ # Colorama is only required for Windows.
'colorama',
],
entry_points='''