summaryrefslogtreecommitdiff
path: root/demoapp
diff options
context:
space:
mode:
authorDuncan McGreggor <duncan@dreamhost.com>2012-04-23 10:07:04 -0400
committerDuncan McGreggor <duncan@dreamhost.com>2012-04-23 10:07:04 -0400
commit9e4be06b20cc5875f78233a6cbfd3aa18e062229 (patch)
tree2721ed0e952670cd0ae1ed7f1bb7ddea3a99acbd /demoapp
parent42cbb39d1466905ab3c5085f1480106e40022537 (diff)
downloadcliff-tablib-9e4be06b20cc5875f78233a6cbfd3aa18e062229.tar.gz
Added a README for the demo app.
Diffstat (limited to 'demoapp')
-rw-r--r--demoapp/README.rst35
1 files changed, 35 insertions, 0 deletions
diff --git a/demoapp/README.rst b/demoapp/README.rst
new file mode 100644
index 0000000..89043a6
--- /dev/null
+++ b/demoapp/README.rst
@@ -0,0 +1,35 @@
+Running demoapp
+===============
+
+Setup
+-----
+
+First, you need to create a virtual environment and switch to it::
+
+ $ pip install virtualenv
+ $ virtualenv .venv
+ $ . .venv/bin/activate
+
+Now, install the demo into the virtual environment::
+
+ $ python setup.py install
+
+Usage
+-----
+
+With cliff and the demo setup up, you can now play with it.
+
+Here are a list of the commands available::
+
+ XXX
+
+Here is some example usage::
+
+ XXX
+
+Cleaning Up
+-----------
+
+Finally, when done, deactivate your virtual environment::
+
+ $ deactivate