summaryrefslogtreecommitdiff
path: root/demoapp
diff options
context:
space:
mode:
Diffstat (limited to 'demoapp')
-rw-r--r--demoapp/README.rst35
1 files changed, 35 insertions, 0 deletions
diff --git a/demoapp/README.rst b/demoapp/README.rst
new file mode 100644
index 0000000..89043a6
--- /dev/null
+++ b/demoapp/README.rst
@@ -0,0 +1,35 @@
+Running demoapp
+===============
+
+Setup
+-----
+
+First, you need to create a virtual environment and switch to it::
+
+ $ pip install virtualenv
+ $ virtualenv .venv
+ $ . .venv/bin/activate
+
+Now, install the demo into the virtual environment::
+
+ $ python setup.py install
+
+Usage
+-----
+
+With cliff and the demo setup up, you can now play with it.
+
+Here are a list of the commands available::
+
+ XXX
+
+Here is some example usage::
+
+ XXX
+
+Cleaning Up
+-----------
+
+Finally, when done, deactivate your virtual environment::
+
+ $ deactivate