summaryrefslogtreecommitdiff
path: root/demoapp
diff options
context:
space:
mode:
authorDuncan McGreggor <duncan@dreamhost.com>2012-04-23 10:32:14 -0400
committerDuncan McGreggor <duncan@dreamhost.com>2012-04-23 10:32:14 -0400
commite8e7404eb1af8d2386150966af6b1691a0c8665c (patch)
tree86deeaf5f58159a24f4a036c23468a62823d3b8b /demoapp
parent3a533e4f3f371e9d042534a6f0dbe39ec2e79c41 (diff)
downloadcliff-tablib-e8e7404eb1af8d2386150966af6b1691a0c8665c.tar.gz
Added a bit more to the README.
Diffstat (limited to 'demoapp')
-rw-r--r--demoapp/README.rst32
1 files changed, 23 insertions, 9 deletions
diff --git a/demoapp/README.rst b/demoapp/README.rst
index a510d1b..e249fdb 100644
--- a/demoapp/README.rst
+++ b/demoapp/README.rst
@@ -9,23 +9,23 @@ First, you need to create a virtual environment and activate it.
::
- $ pip install virtualenv
- $ virtualenv .venv
- $ . .venv/bin/activate
- (.venv)$
+ $ pip install virtualenv
+ $ virtualenv .venv
+ $ . .venv/bin/activate
+ (.venv)$
Next, install ``cliff`` in the environment.
::
- (.venv)$ python setup.py install
+ (.venv)$ python setup.py install
Now, install the demo application into the virtual environment.
::
- (.venv)$ cd demoapp
- (.venv)$ python setup.py install
+ (.venv)$ cd demoapp
+ (.venv)$ python setup.py install
Usage
-----
@@ -36,6 +36,20 @@ To see a list of commands availble, run::
(.venv)$ cliffdemo --help
+One of the available commands is "simple" and running it
+
+::
+
+ (.venv)$ cliffdemo simple
+
+produces the following
+
+::
+
+ sending greeting
+ hi!
+
+
To see help for an individual command, include the command name on the
command line::
@@ -46,5 +60,5 @@ Cleaning Up
Finally, when done, deactivate your virtual environment::
- (.venv)$ deactivate
- $
+ (.venv)$ deactivate
+ $