summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPaul Ganssle <1377457+pganssle@users.noreply.github.com>2022-12-03 15:07:04 -0500
committerGitHub <noreply@github.com>2022-12-03 15:07:04 -0500
commitb04edc08aa3559063b3b097f437941d8c4b84aba (patch)
tree174b2ef9fbd215ad01d123df9034d138a9de3f57 /pyproject.toml
parente8151c15172620d8d55e410f9297564368c886bf (diff)
parentc73a9b183ff0aa2ab2ac8c7c52b61ac6081b6eed (diff)
downloaddateutil-git-master.tar.gz
Merge pull request #1248 from pganssle/add-pre-commitHEADmaster
Add pre commit
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e83d69f..67ad619 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -46,3 +46,21 @@ build-backend = "setuptools.build_meta"
name = "Misc"
showcontent = true
+[tool.black]
+line-length = 80
+
+[tool.isort]
+atomic=true
+force_grid_wrap=0
+include_trailing_comma=true
+known_first_party = ["dateutil"]
+known_third_party=[
+ "pytest",
+ "hypothesis",
+ "six",
+ "freezegun",
+ "mock",
+]
+multi_line_output=3
+use_parentheses=true
+