summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e83d69f..67ad619 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -46,3 +46,21 @@ build-backend = "setuptools.build_meta"
name = "Misc"
showcontent = true
+[tool.black]
+line-length = 80
+
+[tool.isort]
+atomic=true
+force_grid_wrap=0
+include_trailing_comma=true
+known_first_party = ["dateutil"]
+known_third_party=[
+ "pytest",
+ "hypothesis",
+ "six",
+ "freezegun",
+ "mock",
+]
+multi_line_output=3
+use_parentheses=true
+