summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorTimothy Edmund Crosley <timothy.crosley@gmail.com>2020-05-19 21:52:02 -0700
committerGitHub <noreply@github.com>2020-05-19 21:52:02 -0700
commitecffcdd81c16a54b545849ee538c204e108193f9 (patch)
tree3abb17a895098bda6ba2052c2ec761827049f507 /README.md
parent6e274aa8f8844087ba4040261110d9dbce0c156a (diff)
parentd91f45286ca8f7a05e17ff0edc20f35d54a80c7d (diff)
downloadisort-ecffcdd81c16a54b545849ee538c204e108193f9.tar.gz
Merge pull request #1202 from bsolomon1124/doc-pyproject
Docs: mention isort[pyproject] extra in README
Diffstat (limited to 'README.md')
-rw-r--r--README.md9
1 files changed, 8 insertions, 1 deletions
diff --git a/README.md b/README.md
index 1141280e..4df3c38e 100644
--- a/README.md
+++ b/README.md
@@ -110,6 +110,12 @@ Install isort with both formats support:
pip install isort[requirements,pipfile]
```
+Install isort with support for reading configuration from `pyproject.toml`:
+
+```bash
+pip install isort[pyproject]
+```
+
Using isort
===========
@@ -243,7 +249,8 @@ Or, if you prefer, you can add an `isort` or `tool:isort` section to
your project's `setup.cfg` or `tox.ini` file with any desired settings.
You can also add your desired settings under a `[tool.isort]` section in
-your `pyproject.toml` file.
+your `pyproject.toml` file. For `pyproject.toml` support, use
+`pip install isort[pyproject]`.
You can then override any of these settings by using command line
arguments, or by passing in override values to any of the public Python API