summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrien Di Mascio <Adrien.DiMascio@logilab.fr>2009-05-28 15:55:00 +0200
committerAdrien Di Mascio <Adrien.DiMascio@logilab.fr>2009-05-28 15:55:00 +0200
commit9f830611ccb1b541ae6497ff6e3cf2878029a8f1 (patch)
tree1cc27db58eb278128ab2c893093e95a92f453893
parent08d9a46869a44b5c9f443c2ab58d21bb23652d55 (diff)
downloadlogilab-common-version-0_40_1.tar.gz
[debian] provide debian files for jauntylogilab-common-version-0_40_1
-rw-r--r--debian.jaunty/control34
-rwxr-xr-xdebian.jaunty/rules81
2 files changed, 115 insertions, 0 deletions
diff --git a/debian.jaunty/control b/debian.jaunty/control
new file mode 100644
index 0000000..75cddac
--- /dev/null
+++ b/debian.jaunty/control
@@ -0,0 +1,34 @@
+Source: logilab-common
+Section: python
+Priority: optional
+Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
+Uploaders: David Douard <david.douard@logilab.fr>, Fabrice Douchant <fabrice.douchant@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>, Sandro Tosi <morph@debian.org>, Dorothe Sénéchal <dorothee.senechal@logilab.fr>, Adrien Di Mascio <Adrien.DiMascio@logilab.fr>
+Build-Depends: debhelper (>= 5.0.38), python (>= 2.3.5-7)
+Build-Depends-Indep: python-support, python-epydoc, graphviz
+XS-Python-Version: all
+Standards-Version: 3.8.1
+Homepage: http://www.logilab.org/project/logilab-common
+Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
+Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-common/trunk/
+
+Package: python-logilab-common
+Architecture: all
+Provides: ${python:Provides}
+Depends: ${python:Depends}, ${misc:Depends}
+Recommends: python-egenix-mxdatetime
+Conflicts: python-constraint ( <= 0.3.0-4), python-logilab-astng ( <= 0.16.0-1), pylint ( << 0.11.0-1), devtools ( <= 0.9.0-1), logilab-doctools ( <= 0.1.6-4), python-logilab-aspects ( <= 0.1.4-2), python2.3-logilab-common, python2.4-logilab-common
+XB-Python-Version: ${python:Versions}
+Description: useful miscellaneous modules used by Logilab projects
+ logilab-common is a collection of low-level Python packages and modules,
+ designed to ease:
+ .
+ * handling command line options and configuration files
+ * writing interactive command line tools
+ * manipulation files and character strings
+ * interfacing to OmniORB
+ * generating of SQL queries
+ * running unit tests
+ * manipulating tree structures
+ * accessing RDBMS (currently postgreSQL, MySQL and sqlite)
+ * generating text and HTML reports
+ * logging
diff --git a/debian.jaunty/rules b/debian.jaunty/rules
new file mode 100755
index 0000000..f1f9362
--- /dev/null
+++ b/debian.jaunty/rules
@@ -0,0 +1,81 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ # python module build
+ NO_SETUPTOOLS=1 python setup.py -q build --build-purelib build/lib
+
+ # run tests
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ # we need this hack because we have to import "logilab.common.pytest"
+ # but since it's a namespace package, we need to "simulate" it
+ touch $(CURDIR)/build/lib/logilab/__init__.py
+ -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.6/pytest
+ rm -f $(CURDIR)/build/lib/logilab/__init__.py
+endif
+
+ # build doc
+ $(MAKE) -C doc
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ # clean doc
+ $(MAKE) -C doc clean
+
+ NO_SETUPTOOLS=1 python setup.py clean
+
+ [ ! -d build ] || rm -rf build
+
+ find . -name "*.pyc" -delete
+
+ dh_clean build-stamp
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile --root=debian/python-logilab-common/ --install-headers=usr/include/ --install-scripts=usr/bin/
+ # remove test directory
+ rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_install -i
+ dh_pysupport -i
+ dh_installchangelogs -i ChangeLog
+ dh_installexamples -i
+ dh_installdocs -i README doc/apidoc/
+ dh_installman -i
+ dh_link -i
+ dh_compress -i -X.py -X.ini -X.xml -Xtest/ -Xapidoc/
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary-arch:
+
+binary: binary-indep
+.PHONY: build clean binary binary-indep binary-arch