summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinay Sajip <vinay_sajip@yahoo.co.uk>2021-09-09 09:16:38 +0100
committerVinay Sajip <vinay_sajip@yahoo.co.uk>2021-09-09 09:16:38 +0100
commit1ccde768387dc0407eb54dc45025e8f9eaea1a00 (patch)
tree45cbc741987bbb5300efc8d197e3ea98d215d4ee
parent8a3345841a97fdd7fe0a28dd46820f2318195a56 (diff)
parent0ed7e227967b394b4fb3010f24ec0c28d14af82e (diff)
downloadlogutils-git-master.tar.gz
end merge update.HEADmaster
-rw-r--r--.github/workflows/package-tests.yml26
1 files changed, 26 insertions, 0 deletions
diff --git a/.github/workflows/package-tests.yml b/.github/workflows/package-tests.yml
new file mode 100644
index 0000000..89a9007
--- /dev/null
+++ b/.github/workflows/package-tests.yml
@@ -0,0 +1,26 @@
+name: Package tests
+
+on:
+ push:
+ branches: [ master ]
+ pull_request:
+ branches: [ master ]
+
+jobs:
+ build:
+ runs-on: ${{ matrix.os }}
+ strategy:
+ fail-fast: false
+ matrix:
+ os: [ubuntu-latest, macos-latest, windows-latest]
+ python-version: [2.7, 3.7, 3.8, 3.9, pypy2]
+
+ steps:
+ - uses: actions/checkout@v2
+ - name: Set up Python ${{ matrix.python-version }}
+ uses: actions/setup-python@v2
+ with:
+ python-version: ${{ matrix.python-version }}
+ - name: Test with unittest
+ run: |
+ python setup.py test