summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/package-tests.yml26
1 files changed, 26 insertions, 0 deletions
diff --git a/.github/workflows/package-tests.yml b/.github/workflows/package-tests.yml
new file mode 100644
index 0000000..89a9007
--- /dev/null
+++ b/.github/workflows/package-tests.yml
@@ -0,0 +1,26 @@
+name: Package tests
+
+on:
+ push:
+ branches: [ master ]
+ pull_request:
+ branches: [ master ]
+
+jobs:
+ build:
+ runs-on: ${{ matrix.os }}
+ strategy:
+ fail-fast: false
+ matrix:
+ os: [ubuntu-latest, macos-latest, windows-latest]
+ python-version: [2.7, 3.7, 3.8, 3.9, pypy2]
+
+ steps:
+ - uses: actions/checkout@v2
+ - name: Set up Python ${{ matrix.python-version }}
+ uses: actions/setup-python@v2
+ with:
+ python-version: ${{ matrix.python-version }}
+ - name: Test with unittest
+ run: |
+ python setup.py test