summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2016-04-17 23:42:35 +0200
committerGitLab <gitlab@gitlab.com>2016-04-20 14:03:50 +0000
commit90ee875a675240b2501d351f0a10d1ca80ab28f7 (patch)
treeccab1c089f5a81f28680183376659cdcb4916892 /.gitlab-ci.yml
parent232eb4d2b38e76f612386c2ea4e22708ad2c8ab5 (diff)
downloadm2crypto-90ee875a675240b2501d351f0a10d1ca80ab28f7.tar.gz
Switch off PyPy ... supporting it is a really big job.
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml6
1 files changed, 3 insertions, 3 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index ce5cebe..68feccd 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,7 +3,6 @@ stages:
# - python26
- python27
- python34
- - pypy
.python26:
stage: python26
@@ -38,10 +37,11 @@ python34:
allow_failure: yes
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-twisted python3-setuptools
+ - apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools
+ - easy_install3 Twisted
- python3 setup.py clean build test
-pypy:
+.pypy:
stage: pypy
image: pypy:2
when: always