summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2020-12-07 22:56:32 +0100
committerMatěj Cepl <mcepl@cepl.eu>2020-12-07 23:49:55 +0100
commitd9dec89a2d46c21459f9d2644f914f1b3f5d8144 (patch)
tree2b9dcd1c7131b4c37a75dc055575bf70c24c9a5d /.gitlab-ci.yml
parentcb4529c45e96107d754a59c0904311695bddb350 (diff)
downloadm2crypto-d9dec89a2d46c21459f9d2644f914f1b3f5d8144.tar.gz
Some distros don't distribute parameterized
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml9
1 files changed, 6 insertions, 3 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 7f9b4f4..ff74632 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,7 +3,8 @@ python27:
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python-dev openssl python-twisted python-setuptools python-parameterized
+ - apt-get install -y swig libssl-dev python-dev openssl python-twisted python-setuptools python-pip
+ - python -mpip install --user parameterized
- python setup.py clean build test
python35:
@@ -11,7 +12,8 @@ python35:
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-parameterized
+ - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
+ - python3 -mpip install --user parameterized
- python3 setup.py clean build test
python3:
@@ -19,7 +21,8 @@ python3:
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-parameterized
+ - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
+ - python3 -mpip install --user parameterized
- python3 setup.py clean build test
fedora: