summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2019-11-24 23:56:22 +0100
committerMatěj Cepl <mcepl@cepl.eu>2019-11-24 23:56:22 +0100
commit00988b7367744c6dd02568913f2e2a0d89716cae (patch)
tree0668b0c0455c64ca04c9de9ff5a7f471b384f7ee /setup.py
parent1bd4b72bf946c1f5327232de20ec68ba1369daeb (diff)
downloadm2crypto-00988b7367744c6dd02568913f2e2a0d89716cae.tar.gz
Make tests pass again.
1. Python 2.6 needs bundled-in typing module 2. Update Windows OpenSSL version.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4acffff..2ce9424 100644
--- a/setup.py
+++ b/setup.py
@@ -36,6 +36,11 @@ log = logging.getLogger('setup')
REQUIRED_SWIG_VERSION = '2.0.4'
+if sys.version_info[:2] <= (2, 6):
+ sys.path.insert(0, os.path.join(os.path.abspath(os.path.dirname(__file__)),
+ 'tests', 'vendor'))
+
+
if (2, 6) < sys.version_info[:2] < (3, 5):
requires_list = ['typing']
else: