summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAllan Que <allan.que@gmail.com>2018-01-21 15:00:00 -0600
committerMatěj Cepl <mcepl@cepl.eu>2018-01-23 20:54:06 +0100
commit1609131f5b96acdf8b4a1bf12307e2ea8adf8072 (patch)
treeaaf2f2aeab66317734fe3b62e5a0b69a2497c19e /setup.py
parent1767a24d8c2411b66ab73a5a77936f56007ed579 (diff)
downloadm2crypto-1609131f5b96acdf8b4a1bf12307e2ea8adf8072.tar.gz
setup: add upper ver for typing module requirement
* typing module is in the std lib as of python 3.5
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 5fe1620..38610df 100644
--- a/setup.py
+++ b/setup.py
@@ -33,8 +33,7 @@ log = logging.getLogger('setup')
REQUIRED_SWIG_VERSION = '2.0.4'
-
-if sys.version_info[:2] > (2, 6):
+if (2, 6) < sys.version_info[:2] < (3, 5):
requires_list = ['typing']
else:
requires_list = []