summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAllan Que <allan.que@gmail.com>2018-01-22 21:32:15 -0600
committerMatěj Cepl <mcepl@cepl.eu>2018-01-23 20:48:46 +0100
commit1767a24d8c2411b66ab73a5a77936f56007ed579 (patch)
tree41df4ee8909d6575b0fefb0b082dd94919e8fb7a /setup.py
parentc3ef0c67d3342d01926eb7bfea916b140fd8573d (diff)
downloadm2crypto-1767a24d8c2411b66ab73a5a77936f56007ed579.tar.gz
setup: search for include paths that start with ' /'
* modify _get_additional_includes() to only return paths that start with ' /'. Fixes issue on OSX clang.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1d0ed19..5fe1620 100644
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,7 @@ def _get_additional_includes():
stderr=subprocess.PIPE)
_, err = pid.communicate()
err = [line.lstrip() for line in err.decode('utf8').split('\n')
- if line and line[0] == ' ']
+ if line and line.startswith(' /')]
log.debug('additional includes:\n%s', err)
return err