summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-10-01 11:23:50 +0200
committerMatěj Cepl <mcepl@cepl.eu>2017-10-12 17:05:58 +0200
commit63dea7e44148d18a1a087a90c9a6794964d57788 (patch)
tree4552e57aa6bfafb81c99305bd3ede10bd51f9bbc /setup.py
parent676cf9c264165a1f66c01f97d47812593e8f7548 (diff)
downloadm2crypto-63dea7e44148d18a1a087a90c9a6794964d57788.tar.gz
Additional directories for self.library_dirs should be first, not last.
Also, update documentation for building with OpenSSL in non-standard location.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9c794d9..c72da08 100644
--- a/setup.py
+++ b/setup.py
@@ -51,6 +51,7 @@ def _get_additional_includes():
_, err = pid.communicate()
err = [line.lstrip() for line in err.decode('utf8').split('\n')
if line and line[0] == ' ']
+ log.debug('additional includes:\n%s', err)
return err
@@ -211,7 +212,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
# Someday distutils will be fixed and this won't be needed.
self.library_dirs += [os.path.join(self.openssl, 'bin')]
- self.library_dirs += [os.path.join(self.openssl, openssl_library_dir)]
+ self.library_dirs.insert(0, os.path.join(self.openssl, openssl_library_dir))
+ log.debug('self.library_dirs = %s', self.library_dirs)
mkpath(os.path.join(self.build_lib, 'M2Crypto'))