summaryrefslogtreecommitdiff
path: root/docker
diff options
context:
space:
mode:
authorInada Naoki <songofacandy@gmail.com>2020-02-19 00:53:01 +0900
committerGitHub <noreply@github.com>2020-02-19 00:53:00 +0900
commit2849f5582ab154ade7fcd8c23109b1c7bd8d1530 (patch)
treeafa1010428e7b425f73c24740da41083a765af27 /docker
parent12506d8d91ce5a7b76c2d8babe7e2d1e2851d3a2 (diff)
downloadmsgpack-python-2849f5582ab154ade7fcd8c23109b1c7bd8d1530.tar.gz
Build linux and macOS wheels on GitHub Actions. (#409)
Diffstat (limited to 'docker')
-rw-r--r--docker/buildwheel.sh8
1 files changed, 7 insertions, 1 deletions
diff --git a/docker/buildwheel.sh b/docker/buildwheel.sh
index c953127..89a2570 100644
--- a/docker/buildwheel.sh
+++ b/docker/buildwheel.sh
@@ -10,5 +10,11 @@ echo "arch=$ARCH"
for V in "${PYTHON_VERSIONS[@]}"; do
PYBIN=/opt/python/$V/bin
rm -rf build/ # Avoid lib build by narrow Python is used by wide python
- $PYBIN/python setup.py bdist_wheel -p manylinux1_${ARCH}
+ $PYBIN/python setup.py bdist_wheel
+done
+
+cd dist
+for whl in *.whl; do
+ auditwheel repair "$whl"
+ rm "$whl"
done