summaryrefslogtreecommitdiff
path: root/docker
diff options
context:
space:
mode:
authorINADA Naoki <methane@users.noreply.github.com>2016-05-05 02:07:46 +0900
committerINADA Naoki <methane@users.noreply.github.com>2016-05-05 02:07:46 +0900
commit63e23d37f9f3646f0fc3b327ddf1f3e1f200baf5 (patch)
treec35033e4dbf3dd0d6bfb0fb978866ac1fa051682 /docker
parentfc2933853af1910989b51930e63fce5d9f73887a (diff)
downloadmsgpack-python-63e23d37f9f3646f0fc3b327ddf1f3e1f200baf5.tar.gz
travis: Use docker to test 32bit environment (#189)
* travis: testing matrix.include feature to use docker * Add test script for 32bit * Fix OverflowError in 32bit Environment
Diffstat (limited to 'docker')
-rwxr-xr-xdocker/runtests.sh14
1 files changed, 14 insertions, 0 deletions
diff --git a/docker/runtests.sh b/docker/runtests.sh
new file mode 100755
index 0000000..0d74802
--- /dev/null
+++ b/docker/runtests.sh
@@ -0,0 +1,14 @@
+#!/bin/bash
+set -e -x
+
+for V in cp35-cp35m cp34-cp34m cp27-cp27m cp27-cp27mu; do
+ PYBIN=/opt/python/$V/bin
+ $PYBIN/python setup.py install
+ rm -rf build/ # Avoid lib build by narrow Python is used by wide python
+ $PYBIN/pip install pytest
+ pushd test # prevent importing msgpack package in current directory.
+ $PYBIN/python -c 'import sys; print(hex(sys.maxsize))'
+ $PYBIN/python -c 'from msgpack import _packer, _unpacker'
+ $PYBIN/py.test -v
+ popd
+done