summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <inada-n@klab.com>2013-02-03 00:52:05 +0900
committerINADA Naoki <inada-n@klab.com>2013-02-03 00:52:05 +0900
commit1951b197b547c3f12b755790717d799272fbeb34 (patch)
treecfb8a8fe28b86728bb132a82ba81695f5d2e0acf /setup.py
parent22920baae6957e2259a82d0595c2b97fc58fcd02 (diff)
downloadmsgpack-python-1951b197b547c3f12b755790717d799272fbeb34.tar.gz
Skip compile error for extension modules.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 888de09..1055a61 100644
--- a/setup.py
+++ b/setup.py
@@ -46,7 +46,12 @@ class BuildExt(build_ext):
print("Install Cython >= 0.16 or install msgpack from PyPI.")
print("Falling back to pure Python implementation.")
return
- return build_ext.build_extension(self, ext)
+ try:
+ return build_ext.build_extension(self, ext)
+ except Exception as e:
+ print("WARNING: Failed to compile extensiom modules.")
+ print("msgpack uses fallback pure python implementation.")
+ print(e)
exec(open('msgpack/_version.py').read())