summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 888de09..1055a61 100644
--- a/setup.py
+++ b/setup.py
@@ -46,7 +46,12 @@ class BuildExt(build_ext):
print("Install Cython >= 0.16 or install msgpack from PyPI.")
print("Falling back to pure Python implementation.")
return
- return build_ext.build_extension(self, ext)
+ try:
+ return build_ext.build_extension(self, ext)
+ except Exception as e:
+ print("WARNING: Failed to compile extensiom modules.")
+ print("msgpack uses fallback pure python implementation.")
+ print(e)
exec(open('msgpack/_version.py').read())