summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <inada-n@klab.com>2012-08-19 04:17:56 +0900
committerINADA Naoki <inada-n@klab.com>2012-08-19 04:17:56 +0900
commit814c42c2917ca62637ee37344c042174dfb10b4b (patch)
tree50dd63858eeca77aefffa5681e06a2f6ec4f88b4 /setup.py
parent29b4b785d0152c964819bc613a0321214df78c47 (diff)
downloadmsgpack-python-814c42c2917ca62637ee37344c042174dfb10b4b.tar.gz
Change the way to manage version number.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 1 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index b03647a..6148dbd 100644
--- a/setup.py
+++ b/setup.py
@@ -53,13 +53,7 @@ class BuildExt(build_ext):
return build_ext.build_extension(self, ext)
-# make msgpack/__verison__.py
-f = open('msgpack/__version__.py', 'w')
-try:
- f.write("version = %r\n" % (version,))
-finally:
- f.close()
- del f
+exec(open('msgpack/_version.py').read())
version_str = '.'.join(str(x) for x in version[:3])
if len(version) > 3 and version[3] != 'final':