summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog.rst10
-rw-r--r--Makefile4
-rw-r--r--docker/buildwheel.sh11
-rw-r--r--msgpack/_version.py2
4 files changed, 24 insertions, 3 deletions
diff --git a/ChangeLog.rst b/ChangeLog.rst
index 396ccb7..08d49f3 100644
--- a/ChangeLog.rst
+++ b/ChangeLog.rst
@@ -1,6 +1,5 @@
0.5.0
-=====
-:release date: TBD
+======
0.5 is important step toward 1.0. There are some deprecations.
Please read changes carefully.
@@ -20,9 +19,16 @@ Changes
* Pure Python implementation supports packing memoryview object.
+
+0.4.8
+=====
+:release date: 2016-07-29
+
Bugs fixed
----------
+* Calling ext_hook with wrong length. (Only on Windows, maybe. #203)
+
0.4.7
=====
diff --git a/Makefile b/Makefile
index 01d8092..f833bbc 100644
--- a/Makefile
+++ b/Makefile
@@ -26,3 +26,7 @@ clean:
rm -rf build
rm msgpack/*.so
rm -rf msgpack/__pycache__
+
+build-manylinux1-wheel:
+ docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux1_i686 bash docker/buildwheel.sh
+ docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux1_x86_64 bash docker/buildwheel.sh
diff --git a/docker/buildwheel.sh b/docker/buildwheel.sh
new file mode 100644
index 0000000..b654e45
--- /dev/null
+++ b/docker/buildwheel.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+set -e -x
+
+ARCH=`uname -p`
+echo "arch=$ARCH"
+
+for V in cp35-cp35m cp34-cp34m cp27-cp27m cp27-cp27mu; do
+ PYBIN=/opt/python/$V/bin
+ rm -rf build/ # Avoid lib build by narrow Python is used by wide python
+ $PYBIN/python setup.py bdist_wheel -p manylinux1_${ARCH}
+done
diff --git a/msgpack/_version.py b/msgpack/_version.py
index 37c172d..76bd8fb 100644
--- a/msgpack/_version.py
+++ b/msgpack/_version.py
@@ -1 +1 @@
-version = (0, 4, 7)
+version = (0, 4, 8)