summaryrefslogtreecommitdiff
path: root/docker/buildwheel.sh
diff options
context:
space:
mode:
Diffstat (limited to 'docker/buildwheel.sh')
-rw-r--r--docker/buildwheel.sh11
1 files changed, 11 insertions, 0 deletions
diff --git a/docker/buildwheel.sh b/docker/buildwheel.sh
new file mode 100644
index 0000000..b654e45
--- /dev/null
+++ b/docker/buildwheel.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+set -e -x
+
+ARCH=`uname -p`
+echo "arch=$ARCH"
+
+for V in cp35-cp35m cp34-cp34m cp27-cp27m cp27-cp27mu; do
+ PYBIN=/opt/python/$V/bin
+ rm -rf build/ # Avoid lib build by narrow Python is used by wide python
+ $PYBIN/python setup.py bdist_wheel -p manylinux1_${ARCH}
+done