summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2022-12-18 21:24:50 -0800
committerSeth Morton <seth.m.morton@gmail.com>2022-12-18 21:24:50 -0800
commit9193b9c2e43d9cfa25633b85ead62d8a1fecd6cc (patch)
tree8ec3dbf6fecce5331712d09d8d97ed6be682f990
parent48b91687f2c98feabeb6d449134f5d104f46956e (diff)
downloadnatsort-9193b9c2e43d9cfa25633b85ead62d8a1fecd6cc.tar.gz
Remove 3.6 support
CI outright fails with this.
-rw-r--r--.github/workflows/code-quality.yml8
-rw-r--r--.github/workflows/tests.yml2
-rw-r--r--README.rst2
-rw-r--r--setup.cfg1
-rw-r--r--setup.py2
-rw-r--r--tox.ini4
6 files changed, 8 insertions, 11 deletions
diff --git a/.github/workflows/code-quality.yml b/.github/workflows/code-quality.yml
index 89d31f2..c8b3eb0 100644
--- a/.github/workflows/code-quality.yml
+++ b/.github/workflows/code-quality.yml
@@ -20,7 +20,7 @@ jobs:
- name: Set up Python
uses: actions/setup-python@v2
with:
- python-version: '3.6'
+ python-version: '3.8'
- name: Install black
run: pip install black
@@ -38,7 +38,7 @@ jobs:
- name: Set up Python
uses: actions/setup-python@v2
with:
- python-version: '3.6'
+ python-version: '3.8'
- name: Install Flake8
run: pip install flake8 flake8-import-order flake8-bugbear pep8-naming
@@ -56,7 +56,7 @@ jobs:
- name: Set up Python
uses: actions/setup-python@v2
with:
- python-version: '3.6'
+ python-version: '3.8'
- name: Install MyPy
run: pip install mypy hypothesis pytest pytest-mock fastnumbers
@@ -74,7 +74,7 @@ jobs:
- name: Set up Python
uses: actions/setup-python@v2
with:
- python-version: '3.6'
+ python-version: '3.8'
- name: Install Validators
run: pip install twine check-manifest
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index d78fdf9..62dc7c4 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ${{ matrix.os }}
strategy:
matrix:
- python-version: [3.6, 3.7, 3.8, 3.9, "3.10"]
+ python-version: [3.7, 3.8, 3.9, "3.10"]
os: [ubuntu-latest]
extras: [false]
include:
diff --git a/README.rst b/README.rst
index 81f4f8e..f4639b1 100644
--- a/README.rst
+++ b/README.rst
@@ -365,7 +365,7 @@ from the command line with ``python -m natsort``.
Requirements
------------
-``natsort`` requires Python 3.6 or greater.
+``natsort`` requires Python 3.7 or greater.
Optional Dependencies
---------------------
diff --git a/setup.cfg b/setup.cfg
index f909753..786d32f 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -25,7 +25,6 @@ classifiers =
Natural Language :: English
Programming Language :: Python
Programming Language :: Python :: 3
- Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
diff --git a/setup.py b/setup.py
index 314565e..59d31da 100644
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ setup(
version="8.2.0",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
- python_requires=">=3.6",
+ python_requires=">=3.7",
extras_require={"fast": ["fastnumbers >= 2.0.0"], "icu": ["PyICU >= 1.0.0"]},
package_data={"": ["py.typed"]},
zip_safe=False,
diff --git a/tox.ini b/tox.ini
index 19ab53d..10f9db9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,7 +5,7 @@
[tox]
envlist =
- flake8, mypy, py36, py37, py38, py39, py310
+ flake8, mypy, py37, py38, py39, py310
# Other valid environments are:
# docs
# release
@@ -105,8 +105,6 @@ skip_install = true
# Get GitHub actions to run the correct tox environment
[gh-actions]
python =
- 3.5: py35
- 3.6: py36
3.7: py37
3.8: py38
3.9: py39