summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2018-05-02 08:15:10 +0100
committerAlastair Houghton <alastair@alastairs-place.net>2018-05-02 08:15:10 +0100
commit4847e8f34c51f14f14ed31badb3deac46dece29e (patch)
tree5aa74364184c7ecc011defc5e696194f4909c7d9
parentae1dce4408aebc82180f6f65802d697679b2b335 (diff)
downloadnetifaces-git-4847e8f34c51f14f14ed31badb3deac46dece29e.tar.gz
Added more versions to the testing matrix.
-rw-r--r--.travis.yml8
-rw-r--r--appveyor.yml2
-rw-r--r--setup.py3
3 files changed, 13 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index 3d39211..3b6ed94 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -21,8 +21,16 @@ script:
matrix:
include:
- os: linux
+ python: pypy
+ - os: linux
+ python: pypy3
+ - os: linux
python: 2.7
- os: linux
+ python: 3.4
+ - os: linux
+ python: 3.5
+ - os: linux
python: 3.6
- os: osx
language: generic
diff --git a/appveyor.yml b/appveyor.yml
index 0946417..ac17623 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -2,6 +2,8 @@ environment:
matrix:
- PYTHON: "C:\\Python27"
+ - PYTHON: "C:\\Python34"
+ - PYTHON: "C:\\Python35"
- PYTHON: "C:\\Python36"
- PYTHON: "C:\\Python36-x64"
diff --git a/setup.py b/setup.py
index c9d73ce..ab1ad7a 100644
--- a/setup.py
+++ b/setup.py
@@ -593,5 +593,8 @@ setup (name='netifaces',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6'
],
ext_modules=[iface_mod])