summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@alastairs-place.net>2021-05-31 08:26:39 +0100
committerAlastair Houghton <alastair@alastairs-place.net>2021-05-31 08:26:39 +0100
commitec55b59e27542776f55e0f9e3213a75bf8e0f367 (patch)
treed01ac62a2ab8fd5034e0cf2fd1c016a6540d13d8
parenta62a608a44d8f6291776a60ae1e6a040991eef4a (diff)
downloadnetifaces-git-ec55b59e27542776f55e0f9e3213a75bf8e0f367.tar.gz
Bumped versions for releaserelease_0_11_0
-rw-r--r--CHANGELOG18
-rw-r--r--README.rst5
-rw-r--r--setup.py14
3 files changed, 30 insertions, 7 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 66544f0..f238765 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,21 @@
+2021-05-31 Version 0.11.0
+
+ * Added notice about needing a new maintainer.
+ * Fixed link to Travis CI.
+ * Added test.py to the source distribution.
+ * Fixed netmask calculation for IPv6.
+ * Fixes to gateway detection in some edge cases.
+ * Build CPython 2.7 wheels for 64-bit Windows (yes, you should be
+ using Python 3 now, but still).
+
+ Thank-you to Thomas Sibley, Rajendra Dendukuri, Harshal Patel,
+ Jeff Gordon, Sajith Sasidharan and Yuri Sevatz for contributing
+ to this release.
+
+2019-01-02 Version 0.10.9
+
+ * Added missing LICENSE file to MANIFEST.in.
+
2019-01-02 Version 0.10.8
* Fixed a bug that in certain circumstances could lead to an infinite
diff --git a/README.rst b/README.rst
index 7553c85..6625714 100644
--- a/README.rst
+++ b/README.rst
@@ -15,6 +15,11 @@ netifaces 0.10.8
:target: https://ci.appveyor.com/project/al45tair/netifaces/branch/master
:alt: Build Status (Windows)
+.. warning::
+
+ netifaces needs a new maintainer. al45tair is no longer able to maintain it
+ or make new releases due to work commitments.
+
1. What is this?
----------------
diff --git a/setup.py b/setup.py
index 7766f26..191f363 100644
--- a/setup.py
+++ b/setup.py
@@ -22,7 +22,7 @@ else:
output = getattr(builtins, 'print', lambda x: True)
-__version__ = "0.10.9"
+__version__ = "0.11.0"
# Disable hard links, otherwise building distributions fails on OS X
try:
@@ -97,7 +97,7 @@ class my_build_ext(build_ext):
result = True
if status != 0:
result = False
-
+
finally:
os.dup2(mystdout, 1)
os.dup2(mystderr, 2)
@@ -123,7 +123,7 @@ class my_build_ext(build_ext):
results = {}
self.conftestidx = 0
-
+
output("checking for getifaddrs...", end='')
result = results.get('have_getifaddrs', None)
@@ -187,7 +187,7 @@ class my_build_ext(build_ext):
sin.sin_family = AF_INET;
sin.sin_port = 0;
sin.sin_addr.s_addr = htonl (INADDR_LOOPBACK);
-
+
ret = getnameinfo ((struct sockaddr *)&sin, sizeof (sin),
buffer, sizeof (buffer),
NULL, 0,
@@ -409,7 +409,7 @@ class my_build_ext(build_ext):
# lengths, because they're in the sa_len field on just about
# everything but Linux.
output("checking which sockaddr_xxx structs are defined...", end='')
-
+
result = results.get('have_sockaddrs', None)
if result is not None:
cached = '(cached)'
@@ -434,7 +434,7 @@ class my_build_ext(build_ext):
#include <net/if.h>
#include <netinet/in.h>
%(includes)s
-
+
int main (void) {
struct sockaddr_%(sockaddr)s sa;
return 0;
@@ -446,7 +446,7 @@ class my_build_ext(build_ext):
if self.test_build(testrig):
result.append(sockaddr)
-
+
if result:
output('%s. %s' % (' '.join(result), cached))
for sockaddr in result: