summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@coriolis-systems.com>2014-04-28 17:19:56 +0100
committerAlastair Houghton <alastair@coriolis-systems.com>2014-04-28 17:19:56 +0100
commitb20877a0e1a274514f76ff059f7ef20a6d0afdf3 (patch)
tree155ecb5424cd3c588e1ce0a2ec6c040c7f0d8e34
parent62f7145e10fd4d953b43b2fca1b7b3315cc81443 (diff)
downloadnetifaces-b20877a0e1a274514f76ff059f7ef20a6d0afdf3.tar.gz
More Python 3K compatibility.
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 714c127..ee7f408 100644
--- a/setup.py
+++ b/setup.py
@@ -385,8 +385,8 @@ class my_build_ext(build_ext):
results['have_sockaddrs'] = result
- # Save the results to our config.cache file
- myfile = open(cache_file, 'w')
+ # Save the results to our config.cache file
+ myfile = open(cache_file, 'wb')
try:
pickle.dump(results, myfile)
finally: