summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJarrod Millman <jarrod.millman@gmail.com>2017-08-12 19:10:13 -0700
committerJarrod Millman <jarrod.millman@gmail.com>2017-08-12 19:12:45 -0700
commita887ab8505bac1b21ebdd791f6fc35b367467689 (patch)
treeb5e41957b5ace27d2d10bac0901b710a613827b8 /setup.py
parent2ffe4dde82faaa8bc42dc776c63a98629fc8a277 (diff)
downloadnetworkx-a887ab8505bac1b21ebdd791f6fc35b367467689.tar.gz
Update requirements
Make sure our requirements support the same versions of Python we do.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7d59315b..02ee9cd9 100644
--- a/setup.py
+++ b/setup.py
@@ -108,9 +108,9 @@ package_data = {
'networkx.utils': ['tests/*.py']
}
-install_requires = ['decorator>=3.4.0']
+install_requires = ['decorator>=4.1.0']
extras_require = {'all': ['numpy', 'scipy', 'pandas', 'matplotlib',
- 'pygraphviz', 'pydot', 'pyyaml', 'gdal']}
+ 'pygraphviz', 'pydot', 'pyyaml', 'gdal', 'lxml']}
if __name__ == "__main__":