summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorKumar McMillan <kumar.mcmillan@gmail.com>2010-09-01 17:11:45 -0500
committerKumar McMillan <kumar.mcmillan@gmail.com>2010-09-01 17:11:45 -0500
commit66f6b7a4ddc8233a6a94e1daad412e444a76a7c7 (patch)
treea4d1921c92899d6aa29e0b932e88b5874ef76704 /tox.ini
parentb98f0b1e46bfa4a2f11012d1c2d28caf59163864 (diff)
downloadnose-66f6b7a4ddc8233a6a94e1daad412e444a76a7c7.tar.gz
Initial tox environment to run nose in Python 3.1. I'm not quite sure about adding build_tests though, it needs more thought.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 10 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index d181ceb..1c16257 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py27,py26,py25,py24,jython_nodeps,docs
+envlist=py31,py27,py26,py25,py24,jython_nodeps,docs
[testenv]
deps= coverage >=3.2,<3.3
@@ -22,4 +22,13 @@ basepython=jython
# it compiles C extensions
deps=
commands=
+ python selftest.py []
+
+[testenv:py31]
+basepython=python3.1
+# coverage not yet available for 3...
+deps=
+distribute=True
+commands=
+ python setup.py build_tests
python selftest.py [] \ No newline at end of file