summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 10 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index d181ceb..1c16257 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py27,py26,py25,py24,jython_nodeps,docs
+envlist=py31,py27,py26,py25,py24,jython_nodeps,docs
[testenv]
deps= coverage >=3.2,<3.3
@@ -22,4 +22,13 @@ basepython=jython
# it compiles C extensions
deps=
commands=
+ python selftest.py []
+
+[testenv:py31]
+basepython=python3.1
+# coverage not yet available for 3...
+deps=
+distribute=True
+commands=
+ python setup.py build_tests
python selftest.py [] \ No newline at end of file