summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorVlastimil Zíma <vlastimil.zima@nic.cz>2018-01-22 08:24:47 +0100
committerVlastimil Zíma <vlastimil.zima@nic.cz>2018-01-22 08:24:47 +0100
commitab72d3501929655515c35d1e5ac0e3373b1c3da7 (patch)
tree67eb7d21cad05ef3b5cad593e5436f1ed769a38d /Makefile
parent8f0ff0d27771514d16a415b8ac76d18ea0809f38 (diff)
parent7a94df871477bacf986c3de310b59a204fb62249 (diff)
downloadopenid-ab72d3501929655515c35d1e5ac0e3373b1c3da7.tar.gz
Merge branch 'update-tests'
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 2cba277..2a2b1a4 100644
--- a/Makefile
+++ b/Makefile
@@ -1,13 +1,13 @@
.PHONY: test coverage isort check-all check-isort check-flake8
test:
- python admin/runtests
+ PYTHONPATH="examples" DJANGO_SETTINGS_MODULE="djopenid.settings" python -m unittest discover
coverage:
- python-coverage erase
+ python -m coverage erase
-rm -r htmlcov
- python-coverage run --branch --source="." admin/runtests
- python-coverage html --directory=htmlcov
+ PYTHONPATH="examples" DJANGO_SETTINGS_MODULE="djopenid.settings" python -m coverage run --branch --source="." openid/test/__init__.py discover
+ python -m coverage html --directory=htmlcov
isort:
isort --recursive .