summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2015-06-08 08:51:02 -0700
committerRyan Petrello <lists@ryanpetrello.com>2015-06-08 08:51:29 -0700
commit0001a9d94da76545991afbfb5274e8b8bacac888 (patch)
tree252b80326948e5196c9a0442ea290285a504d5b5
parentd3159f1d6bec06845b152de836793f4454d95804 (diff)
downloadpecan-0001a9d94da76545991afbfb5274e8b8bacac888.tar.gz
Fix broken wsme-stable tests as of the latest 0.7.0 release.
Change-Id: I7b0c7c7fe423fd29b0792f9708b940116e6914c1
-rw-r--r--tox.ini7
1 files changed, 4 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index a9bfc81..593f2ad 100644
--- a/tox.ini
+++ b/tox.ini
@@ -96,10 +96,11 @@ basepython = python2.7
deps = nose
ipaddr
simplegeneric
-changedir = {envdir}/build/wsme
-commands = pip install --build {envdir}/build --pre --no-clean --no-use-wheel wsme
- {envdir}/bin/python setup.py develop
+changedir = {envdir}/src
+commands = pip install --download {envdir}/src --pre --no-deps --no-clean --no-use-wheel wsme
+ sh -c "find -iname 'wsme*.tar.gz' | xargs tar --strip-components 1 -xf"
{envdir}/bin/pip install -U {toxinidir} # install pecan-dev
+ {envdir}/bin/pip install .
nosetests -v tests/pecantest
[testenv:wsme-tip]