summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJenkins <jenkins@review.openstack.org>2015-05-28 17:38:42 +0000
committerGerrit Code Review <review@openstack.org>2015-05-28 17:38:42 +0000
commit17d5357003f65249aebbf6ee08bf38cc6bf40b63 (patch)
tree4d12d343e8e66f59f4b85b6e9e36fb2e5e93b120
parent6b1d0f00028754807b671de122134b5bee5a12c1 (diff)
parent74995b12c52ef0f433a0ca0ba01ee01109dedbae (diff)
downloadpecan-17d5357003f65249aebbf6ee08bf38cc6bf40b63.tar.gz
Merge "Version increment."0.9.0
-rw-r--r--docs/source/changes.rst26
-rw-r--r--setup.py2
2 files changed, 27 insertions, 1 deletions
diff --git a/docs/source/changes.rst b/docs/source/changes.rst
index 5cf6f4c..ce3a3aa 100644
--- a/docs/source/changes.rst
+++ b/docs/source/changes.rst
@@ -1,3 +1,29 @@
+0.9.0
+=====
+* Support for Python 3.2 has been dropped.
+* Added a new feature which allows users to specify custom path segments for
+ controllers. This is especially useful for path segments that are not
+ valid Python identifiers (such as path segments that include certain
+ punctuation characters, like `/some/~path~/`).
+* Added a new configuration option, `app.debugger`, which allows developers to
+ specify an alternative debugger to `pdb` (e.g., `ipdb`) when performing
+ interactive debugging with pecan's `DebugMiddleware`.
+* Changed new quickstart pecan projects to default the `pecan` log level to
+ `DEBUG` for development.
+* Fixed a bug that prevented `staticmethods` from being used as controllers.
+* Fixed a decoding bug in the way pecan handles certain quoted URL path
+ segments and query strings.
+* Fixed several bugs in the way pecan handles Unicode path segments (for
+ example, now you can define pecan routes that contain emoji characters).
+* Fixed several bugs in RestController that caused it to return `HTTP 404 Not
+ Found` rather than `HTTP 405 Method Not Allowed`. Additionally,
+ RestController now returns valid `Allow` headers when `HTTP 405 Method Not
+ Allowed` is returned.
+* Fixed a bug which allowed special pecan methods (`_route`, `_lookup`,
+ `_default`) to be marked as generic REST methods.
+* Added more emphasis in pecan's documentation to the need for `debug=False` in
+ production deployments.
+
0.8.3
=====
* Changed pecan to more gracefully handle a few odd request encoding edge
diff --git a/setup.py b/setup.py
index e2f6d6e..6500d88 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ import platform
from setuptools import setup, find_packages
-version = '0.8.3'
+version = '0.9.0'
#
# determine requirements