summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2015-04-29 11:23:23 -0400
committerRyan Petrello <lists@ryanpetrello.com>2015-04-29 11:23:23 -0400
commit760f4344717e9f41877929d9366146c379d53e3f (patch)
tree197e6fef77deb60eaa39eaa6bd942728a982fc62
parent87b8d00a2ebcb6b2ff3af567249d5065ed135bbd (diff)
downloadpecan-760f4344717e9f41877929d9366146c379d53e3f.tar.gz
Drop support for Python 3.2.
Change-Id: I3586dcdb6202282f244d61e51420053dba20bb28
-rw-r--r--pecan/configuration.py4
-rw-r--r--setup.py5
-rw-r--r--tox.ini22
3 files changed, 4 insertions, 27 deletions
diff --git a/pecan/configuration.py b/pecan/configuration.py
index dce6103..6260723 100644
--- a/pecan/configuration.py
+++ b/pecan/configuration.py
@@ -5,7 +5,7 @@ import sys
import six
-if sys.version_info >= (3, 3):
+if six.PY3:
from importlib.machinery import SourceFileLoader
else:
import imp
@@ -166,7 +166,7 @@ def conf_from_file(filepath):
# This provides more verbose import-related error reporting than exec()
absname, _ = os.path.splitext(abspath)
basepath, module_name = absname.rsplit(os.sep, 1)
- if sys.version_info >= (3, 3):
+ if six.PY3:
SourceFileLoader(module_name, abspath).load_module(module_name)
else:
imp.load_module(
diff --git a/setup.py b/setup.py
index 248b25c..f72b539 100644
--- a/setup.py
+++ b/setup.py
@@ -43,6 +43,7 @@ except:
tests_require = requirements + [
'virtualenv',
+ 'Jinja2',
'gunicorn',
'mock',
'sqlalchemy'
@@ -60,9 +61,6 @@ else:
# Genshi added Python3 support in 0.7
tests_require += ['Genshi>=0.7']
-if sys.version_info < (3, 0) or sys.version_info >= (3, 3):
- tests_require += ['Jinja2']
-
#
# call setup
#
@@ -87,7 +85,6 @@ setup(
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: Implementation :: PyPy',
diff --git a/tox.ini b/tox.ini
index 0738c4b..74e3088 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py32,py33,py34,scaffolds-26,scaffolds-27,scaffolds-32,scaffolds-33,scaffolds-34,scaffolds-26-rest-api,scaffolds-27-rest-api,scaffolds-32-rest-api,scaffolds-33-rest-api,scaffolds-34-rest-api,pep8
+envlist = py26,py27,py33,py34,scaffolds-26,scaffolds-27,scaffolds-33,scaffolds-34,scaffolds-26-rest-api,scaffolds-27-rest-api,scaffolds-33-rest-api,scaffolds-34-rest-api,pep8
[testenv]
commands={envpython} setup.py test -v {posargs}
@@ -51,26 +51,6 @@ commands=pecan create testing123 rest-api
pep8 --repeat --show-source testing123/setup.py testing123/testing123
{envpython} {toxinidir}/pecan/tests/scaffold_builder.py
-[testenv:scaffolds-32]
-basepython = python3.2
-deps = {[testenv:scaffolds-base]deps}
-changedir={[testenv:scaffolds-26]changedir}
-commands=pecan create testing123
- {envpython} testing123/setup.py install
- {envpython} testing123/setup.py test -q
- pep8 --repeat --show-source testing123/setup.py testing123/testing123
- {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
-
-[testenv:scaffolds-32-rest-api]
-basepython = python3.2
-deps = {[testenv:scaffolds-base]deps}
-changedir={[testenv:scaffolds-26]changedir}
-commands=pecan create testing123 rest-api
- {envpython} testing123/setup.py install
- {envpython} testing123/setup.py test -q
- pep8 --repeat --show-source testing123/setup.py testing123/testing123
- {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
-
[testenv:scaffolds-33]
basepython = python3.3
deps = {[testenv:scaffolds-base]deps}