summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Lee <IanLee1521@gmail.com>2016-06-25 21:00:15 -0700
committerIan Lee <IanLee1521@gmail.com>2016-06-25 21:00:15 -0700
commit5aaada759bcb9bdf023c79ee46f162452de9439f (patch)
tree20ca7a07dd5f0a60fc3993b37c6e796e4870feff
parent599aac5c78b7f5c7bba0c433233ffe8573c0f96d (diff)
downloadpep8-gh-502.tar.gz
Fixed all but the last test casegh-502
-rw-r--r--testsuite/test_all.py7
-rw-r--r--testsuite/test_api.py4
2 files changed, 7 insertions, 4 deletions
diff --git a/testsuite/test_all.py b/testsuite/test_all.py
index 08f9ea9..2161b72 100644
--- a/testsuite/test_all.py
+++ b/testsuite/test_all.py
@@ -39,8 +39,11 @@ class PycodestyleTestCase(unittest.TestCase):
msg='%s failure(s)' % report.total_errors)
def test_own_dog_food(self):
- files = [pycodestyle.__file__.rstrip('oc'), __file__.rstrip('oc'),
- os.path.join(ROOT_DIR, 'setup.py')]
+ files = [
+ pycodestyle.__file__.rstrip('oc'),
+ __file__.rstrip('oc'),
+ os.path.join(ROOT_DIR, 'setup.py')
+ ]
report = self._style.init_report(pycodestyle.StandardReport)
report = self._style.check_files(files)
self.assertFalse(report.total_errors,
diff --git a/testsuite/test_api.py b/testsuite/test_api.py
index 4d8b7b2..6eb9f04 100644
--- a/testsuite/test_api.py
+++ b/testsuite/test_api.py
@@ -166,7 +166,7 @@ class APITestCase(unittest.TestCase):
self.assertEqual(pep8style.options.filename, ['*.py'])
self.assertEqual(pep8style.options.format, 'default')
self.assertEqual(pep8style.options.select, ())
- self.assertEqual(pep8style.options.ignore, ('E226', 'E24'))
+ self.assertEqual(pep8style.options.ignore, ('E226', 'E24', 'W504'))
self.assertEqual(pep8style.options.max_line_length, 79)
def test_styleguide_ignore_code(self):
@@ -182,7 +182,7 @@ class APITestCase(unittest.TestCase):
self.assertEqual(options.select, ())
self.assertEqual(
options.ignore,
- ('E121', 'E123', 'E126', 'E226', 'E24', 'E704', 'W503')
+ ('E121', 'E123', 'E126', 'E226', 'E24', 'E704', 'W503', 'W504')
)
options = parse_argv('--doctest').options