summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorIan Lee <IanLee1521@gmail.com>2016-11-14 10:36:03 -0800
committerIan Lee <IanLee1521@gmail.com>2016-11-14 10:36:03 -0800
commit659ef94726c5c18385e7f35a5dce792f91d3601b (patch)
treeb81acb57ffdb4b2ad65f218291c0c7395b65c6c4 /Makefile
parent020d6ff6a85c237b0bdaa4c50625e6385dcddc16 (diff)
downloadpep8-659ef94726c5c18385e7f35a5dce792f91d3601b.tar.gz
Added Makefile to handle proper permissions in releases
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 366f580..d24a595 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,6 @@
+release:
+ umask 022 && chmod -R a+rX . && python setup.py sdist bdist_wheel
+
test :
python pycodestyle.py --testsuite testsuite