summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGeorgi Valkov <georgi.t.valkov@gmail.com>2017-08-27 22:10:17 +0200
committerGeorgi Valkov <georgi.t.valkov@gmail.com>2017-08-27 22:12:23 +0200
commita986c8d6a98c099332df4c2255350b6c756f85ad (patch)
tree10a95d8c00ad4ca2c201d8ef2b3cee7c879fa72e /Makefile
parentcbef61c58f8b1b3b5e2fc3c2414bcac4303538ce (diff)
downloadply-a986c8d6a98c099332df4c2255350b6c756f85ad.tar.gz
Simple makefile for common tasks
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b13d007
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+PYTHON ?= python
+
+test:
+ cd test && $(PYTHON) testlex.py
+ cd test && $(PYTHON) testyacc.py
+
+wheel:
+ $(PYTHON) setup.py bdist_wheel
+
+sdist:
+ $(PYTHON) setup.py sdist
+
+upload: wheel sdist
+ $(PYTHON) setup.py bdist_wheel upload
+ $(PYTHON) setup.py sdist upload
+
+.PHONY: test wheel sdist upload