summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b13d007
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+PYTHON ?= python
+
+test:
+ cd test && $(PYTHON) testlex.py
+ cd test && $(PYTHON) testyacc.py
+
+wheel:
+ $(PYTHON) setup.py bdist_wheel
+
+sdist:
+ $(PYTHON) setup.py sdist
+
+upload: wheel sdist
+ $(PYTHON) setup.py bdist_wheel upload
+ $(PYTHON) setup.py sdist upload
+
+.PHONY: test wheel sdist upload