summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2019-11-04 07:47:54 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2019-11-04 15:47:54 +0800
commitfc204a928fb08101961a4295cad6048bd45e6829 (patch)
treeb323aa27f62de395380223ecfa6f7ac059ac48dd
parentff5a4127f48143bb5c14a5340584c0ddb3c121ef (diff)
downloadpsutil-fc204a928fb08101961a4295cad6048bd45e6829.tar.gz
add PEP 517/8 build backend and requirements specification (#1565)
-rw-r--r--MANIFEST.in1
-rw-r--r--pyproject.toml6
2 files changed, 7 insertions, 0 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 027e4e94..5532ec5d 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -135,3 +135,4 @@ include scripts/who.py
include scripts/winservices.py
include setup.py
include tox.ini
+include pyproject.toml
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 00000000..7f59610c
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,6 @@
+[build-system]
+requires = [
+ "setuptools >= 41.0.0",
+ "wheel >= 0.29.0",
+]
+build-backend = 'setuptools.build_meta'